Muni-Link - Issues sending Biller Initiated Files (BIF) for new accounts if Invoice Cloud is in use – Incident details

All systems operational

Issues sending Biller Initiated Files (BIF) for new accounts if Invoice Cloud is in use

Resolved
Degraded performance
Started 5 months agoLasted about 3 hours

Affected

Payment Providers

Degraded performance from 2:48 PM to 6:10 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    This includes brand new accounts and accounts created from a finalization. We are actively working to correct the issue and will provide an update once we have reached a resolution.