Muni-Link - We are experiencing degraded performance due to ongoing service provider issues – Incident details

All systems operational

We are experiencing degraded performance due to ongoing service provider issues

Resolved
Degraded performance
Started 14 days agoLasted about 20 hours

Affected

Billing

Degraded performance from 3:52 PM to 11:58 AM

Service Orders

Degraded performance from 3:52 PM to 11:58 AM

Service Lines

Degraded performance from 3:52 PM to 11:58 AM

Notifications

Degraded performance from 3:52 PM to 11:58 AM

Customer Portal v1

Degraded performance from 3:52 PM to 11:58 AM

Customer Portal v2

Degraded performance from 3:52 PM to 11:58 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Most problems appear to be resolved, we will continue to monitor the situation.

  • Identified
    Identified

    Due to widespread issues today with our service provider (Amazon AWS) there are reports of sporadic problems within the software suite. We are monitoring the situation and will provide updates as we have them.