Muni-Link - Intermittent problems loading pages within Muni-Link – Incident details

All systems operational

Intermittent problems loading pages within Muni-Link

Resolved
Degraded performance
Started 6 months agoLasted 39 minutes

Affected

Billing

Degraded performance from 7:20 PM to 8:00 PM

Authentication

Degraded performance from 7:20 PM to 8:00 PM

Updates
  • Resolved
    Resolved

    The incident is resolved are system performance is restored.

  • Monitoring
    Monitoring

    Performance appears to have been restored, we are continuing to monitor the situation.

  • Investigating
    Investigating

    Some customers are reporting issues with the inability to load certain pages within Muni-Link. We are currently investigating the issue and will post updates as we work towards a resolution