Muni-Link - Some customers are reporting the inability to access certain parts of the system – Incident details

All systems operational

Some customers are reporting the inability to access certain parts of the system

Resolved
Partial outage
Started 5 months agoLasted 18 minutes

Affected

Billing

Operational from 3:04 PM to 3:22 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We are investigating an incident that is causing some customers to be unable to access certain parts of the system