Muni-Link - Issues Identified with the Service Orders module – Incident details
All systems operational
Issues Identified with the Service Orders module
Resolved
Degraded performance
Started about 1 month agoJuly 24, 2026Lasted about 2 hoursJuly 24, 20262:053:54 PMUTC
Affected
Service Orders
Degraded performance from 2:05 PM to 3:54 PM
Updates
Resolved
UTC
Resolved
UTC
Services orders has been reverted to prior version, reported disruptions are resolved.
Identified
UTC
Identified
UTC
We are aware of issues in the Service Orders module this morning. The issues are identified, several hotfixes have already been applied and the remainder will be fixes as they are available.